Sid Meier’s Civilization® VI

Sid Meier’s Civilization® VI

Civilization VI offers new ways to interact with your world, expand your empire across the map, advance your culture, and compete against history’s greatest leaders to build a civilization that will stand the test of time. Play as one of 20 historical leaders including Roosevelt (America) and Victoria (England).

Minimum system requirements: 

OS: SteamOS, Ubuntu 16.04 (64bit)Processor: Intel Core i3 530 or AMD A8-3870Memory: 6 GB RAMGraphics: 1 GB VRAM Minimum - NVIDIA GeForce 650Storage: 15 GB available spaceAdditional Notes: IMPORTANT NOTICE: ATI and INTEL chipsets are NOT supported to run Civilization VI LINUX. Don't meet the above requirements? Running on a unique distro? That doesn't mean your configuration wont run Civ VI! Visit the Civilization VI community page to share your experience with other Linux players and learn about how to send bugs to Aspyr. Your feedback will help us improve Civ VI Linux and future AAA Linux releases!

Comments