The Spatials

The Spatials

It's the year 5781 -- and you have been chosen to build and lead a space station in a wild corner of the galaxy! Attract visitors and explore hundreds of planets to fund your station.

Minimum system requirements: 

OS: Ubuntu 14.04Processor: 1.3 Ghz or higher, 64 bit onlyMemory: 4096 MB RAMGraphics: Accelerated OpenGL 2.0 or higher under X11Storage: 350 MB available space

External links:
Developer: Weird and Wry

Comments